Category Archives: Asterisk

Error code 9009 due to Missing ResGen.exe

I have this error :
When compiling a certain Asterisk.net.dll program, the error is showing :

The command “C:\Program Files (x86)\Microsoft Visual Studio 8\SDK\v2.0\Bin\ResGen.exe” “C:\Users\jojo\Desktop\project\Asterisk.NET.1.6.3.1\Asterisk.NET.Test\fastagi-mapping.resx” fastagi-mapping.resources” exited with code 9009. Asterisk.NET.Test

I’m using MS Visual Studio 2008, and please note that the location of Resgen now is in : C:\Program Files\Microsoft SDKs\Windows\v6.0A\

So changing the “C:\Program Files (x86)\Microsoft Visual Studio 8\SDK\v2.0\Bin\ResGen.exe”

to “@”%ProgramFiles%\Microsoft SDKs\Windows\v6.0A\Bin\ResGen.exe”. fixes it.

HP Compaq PC that uses Intel 82566DM network problem in Linux

The problem of this pc is upon installation of Centos 5.7, the network is up but if you ping the other pc its just saying “Destination unreachable”.

The fix for this problem is this:

 

1) Download the  http://sourceforge.net/projects/e1000/ driver from that site. Note the e1000 not e100, this is gigabit..

2) tar xfz e1000-<x.x.x>.tar.gz

3) cd e1000-<x.x.x>/src/

4) make install

5) modprobe e1000

 

After doing the the #5, do the command service network restart in the CLI.

HTH

 

Fixing the “Permission denied” error on /var/lib/asterisk/agi-bin/dialparties.agi

A client calls us earlier  complaining that their  incoming calls are not going through. The call just drops  in. I’ve tried to trace also their log full the /var/log/asterisk/full confirming the issue.  Upon tracing the log file, I can see that there is entries that says “Permission denied”  during my call attempt.

 


[Aug 23 11:09:52] VERBOSE[32336] pbx.c: -- Executing [s@macro-dial:3] AGI("DAHDI/77-1", "dialparties.agi") in new stack
[Aug 23 11:09:52] VERBOSE[32336] res_agi.c: -- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
[Aug 23 11:09:52] VERBOSE[32337] app_mixmonitor.c: == Begin MixMonitor Recording DAHDI/77-1
[Aug 23 11:09:52] VERBOSE[32336] res_agi.c: dialparties.agi: Failed to execute '/var/lib/asterisk/agi-bin/dialparties.agi': Permission denied
[Aug 23 11:09:52] VERBOSE[32336] pbx.c: -- Executing [s@macro-dial:4] NoOp("DAHDI/77-1", "Returned from dialparties with no extensions to call and DIALSTATUS: ") in new stack
[Aug 23 11:09:52] VERBOSE[32336] pbx.c: -- Executing [s@macro-exten-vm:10] GotoIf("DAHDI/77-1", "0?exit,return") in new stack
[

 

The issue though is just fixed by doing the chmod on /var/lib/asterisk/agi-bin/dialparties.agi.

Just do : chmod 777 /var/lib/asterisk/agi-bin/dialparties.agi

Calling again the  dialer server  after that ‘fix’  and my call went through.